Seite 2 von 3

Re: Audio Codec minimiert delay

Verfasst: 17 Jan 2017, 16:50
von pavel
schlagen bei Euch auch die Signale vom I2S auf den Empfänger durch ?


Hello Peter,

The frequency of the BCLK clock signal generated by the codec board is 3072 kHz (64 * 48 kHz). Last time I checked, it was clearly seen with all its odd harmonics.

Best regards,

Pavel

Re: Audio Codec minimiert delay

Verfasst: 13 Mär 2017, 15:44
von DF5WW
Eine Frage zum Codec Board. Ich hatte das ja bei meinem RPi gleich mitgeliefert bekommen es war/ist halt nur noch nicht verbaut.
Wie bekomme ich raus welche Frequenz der verbaute Quarz hat. Es steht ja keine MHz Bezeichnung drauf sondern nur eine Nummer, in meinem Fall 480ECSR.
Wäre das die korrekte Variante oder die falsche oder ist das daraus überhaupt nicht zu ersehen.

Falls der falsche gleich die Anschlussfrage, wo bekomme ich einen in passender Grösse mit der richtigen Frequenz ? :oops: :oops:

Re: Audio Codec minimiert delay

Verfasst: 13 Mär 2017, 18:46
von DH1KLM
habe mal gegoogled und das hier gefunden.

    RS component (UK) seems sending Audio Codec Proto with a wrong crystal.
    The WM8731 should work as a master device, which sending clocks to Pi.
    RS component one has 16MHz crystal other than 12.288Mhz.
    This is what I get, for example, 64k when setting as 48k ---- 64k/48k = 16/12m...

    Note the crystal has not freq. on it, it comes with a number --->480ECSR
Quelle: https://github.com/raspberrypi/linux/issues/1672

Sieht für mich so aus als wäre der 480ECSR genau der falsche (16MHz) Quarz.

Aber es haben ja viele hier dieses Teil im Einsatz und werden das aufklären.

73 de Sigi, DH1KLM

Re: Audio Codec minimiert delay

Verfasst: 13 Mär 2017, 19:09
von DD8JM
Ich würde es einfach mal einbauen, kann nichts passieren und schauen ob man was hört und ob es verstänlich ist.

Dann kann man sich immer noch einen Quarz bei Reichelt bestellen.

Viele Grüße

Jörg

Re: Audio Codec minimiert delay

Verfasst: 13 Mär 2017, 21:05
von DF5WW
Hallo Sigi und Jörg,

Danke zunächst mal für die Antworten. Das eigentlich nichts passieren kann ist schon klar denn das Ding hat halt eben nur eine andere Quarzfrequenz. Dachte halt es gäbe Referenznummern um das gleich vor dem Einbau feststellen zu können.
Da ich aber die zusätzliche Hardware sowieso über Adapterboards für die Steckplätze anschliessen werde ist es aber auch eigentlich erstmal Wurscht. Man kann ja einfach abstecken und dann den Quarz wechseln. Aber da man ja sowieso auf beide Steckplätze muss werde ich mir erstmal noch einige der Adapterboards besorgen (hab derzeit nur eines). Da kann man dann die Komponenten schön voneinander trennen :-) ;-)

Re: Audio Codec minimiert delay

Verfasst: 13 Mär 2017, 21:36
von dj9xg-Uwe
Ich habe bei Ebay ein Audio Codec Board für nur 8,70€ frei Haus aus China gefunden .. das hat den richtigen Quartz und dürfte nach Anpassungen auch für Red Pitaya funktionieren.. dafür sind auch smtliche Spezifikationen im Internet verfügbar.
Hier die Ebay URL:
http://www.ebay.de/itm/172318492557?_tr ... EBIDX%3AIT

und hier ein PDF mit der genauen Beschreibung:

www.vlsi.fi/fileadmin/datasheets/vs1003.pdf

Re: Audio Codec minimiert delay

Verfasst: 14 Mär 2017, 11:14
von Uli DF5SF
Hallo Uwe,

hast du Erfahrung mit dem Board ??
Ich bin der Meinung, dass es nicht funktionieren kann oder nur nach extrem aufwendigen Software Änderungen.

Re: Audio Codec minimiert delay

Verfasst: 14 Mär 2017, 14:28
von dj9xg-Uwe
nein kein Erfahrung hatte das bei einer Suche nach Audio Codec gefunden.. Software muß natürlich angepaßt werden da die Interface kein I2C Bus ist.

Re: Audio Codec minimiert delay

Verfasst: 17 Mär 2017, 22:38
von dc2pd
Das ist ein MP3 Codec. Ist hierfür nicht zu gebrauchen.

Re: Audio Codec minimiert delay

Verfasst: 08 Apr 2017, 18:43
von klapauzius
Hallo zusammen,

ich bekomme meinen Audiocodec nicht ans laufen. Der Quartz auf dem Protoboard ist ein "ATS122SM", ist also wenn ichs nicht vollkommen verdreht haben die richtige (12,9MHZ) Version.Verdrahtung ist imo gut, die i2c Hardware "dahinter" tut was sie soll und die finde ich auch mit i2cdetect (-y -r 0) in der Shell. Allerdings vom Protoboard nirgends eine Spur.

Hat jemand einen heißen Tip für mich?

vy 73
Sascha

Re: Audio Codec minimiert delay

Verfasst: 11 Apr 2017, 10:12
von klapauzius
Hat sich dann unterdessen erledigt. Der Codec ist wohl mit i2cdetect nicht zu finden weil er auf dem Bus nicht als Slave läuft. Audio In und Out laufen jetzt prima, wobei mir der Sound über PowerSDR besser gefällt. Ich will aber nicht ausschliessen dass das an meinem (hundert Jahre alten) Sharp Headset liegt

In diesem Sinne
Beste Grüße
Sascha

Re: Audio Codec minimiert delay

Verfasst: 14 Jul 2017, 22:18
von Peter DL1PSJ
Hallo zusammen,
ich hab mal eine Frage zu dem Audio Codec WM8731.
Ich hab das Protoboard vor einiger zeit bekommen und auch eingebaut. Es hat auch einige Zeit gut funktioniert mit einem kleinen Audioverstärker von plessey SL6310 und einem Heil Mikro.
Seit kurzem ist der Mikofoneingang ausgefallen, obwohl das Signal am Codec anliegt. Audioausgang geht weiterhin hervorragend, kein Problem.
Bevor ich jetzt den Codec selbst austausche, wollte ich mal hier fragen, ob jemand ähnliche Erfahrungen gemacht hat oder was ich noch messen kann, um die Ursache herauszufinden.
Ist der A/D Wandler im WM8731 so empfindlich, dass er abgeschossen werden kann?
Ich habe auch in der Applikation zu dem Kondensator C23 einen 1uf Keramikkondensator parallelgeschaltet.
In der PowerSDR mit VAC1 funktioniert alles reibungslos.

Re: Audio Codec minimiert delay

Verfasst: 10 Aug 2017, 14:18
von DL5BCA
Hallo OMs,

ich habe gestern von Eibtron das Audio CODEC (WM8731) Proto Board - MIKROE-506 bekommen.
Gestern gemäß der oben abgebildeten Anleitung die Verkabelung zwisch Codec und RP erstellt.
Ich konnte den RP "nur" mit dem Raspi ansteuern.
Es kam kein Pieps aus dem Codec.

Den RP habe ich nach der 1. Anleitung von Jörg hier im Forum aufgesetzt und mit Autostart komplettiert.

Muss ich noch irgendwas machen, damit aus dem Codec der Ton kommt, bzw. der Eingang für Mikro genutzt werden kann?

73 Thomas DL5BCA

Re: Audio Codec minimiert delay

Verfasst: 10 Aug 2017, 14:32
von DD8JM
Hallo Thomas,

bei PowerSDR muss man VAC1 ausschalten, damit das Codec-Board übernimmt, wie das mit Deiner Software auf dem Raspberry Pi ist kann ich nicht sagen.

Vielleicht ist es da auch so.

73 Jörg

Re: Audio Codec minimiert delay

Verfasst: 10 Aug 2017, 14:36
von DL5BCA
Hallo Jörg,
danke für die schnelle Antwort.

Ich nutze natürlich das PiHPSR.
Da hatte ich schon einige OMs mit Bauvorstellungen gesehen, die auch das Codec verbaut hatten.

73 Thomas DL5BCA

Re: Audio Codec minimiert delay

Verfasst: 10 Aug 2017, 17:55
von DL5BCA
Hallo,
jetzt steuere ich den RP mit PowerSDR 3.3.9 an.
VAC1 ist abgeschaltet.. Aus dem Codec kommt kein Audio.

Kann es an der Software im RP liegen.
Ich bin mir nicht sicher, ob ich auch die richtige Version installiert habe.

73 Thomas

PS: Gerade mit einem Zähler gemessen: der Quarz des Codec schwingt auf 12.288Mhz.

Re: Audio Codec minimiert delay

Verfasst: 10 Aug 2017, 18:30
von DD8JM
Hallo Thomas,

hier die letzte Version von Pavel:

https://www.dropbox.com/sh/5fy49wae6xwxa8a/AAD3bGp3ptaQ-VE-adG1SijKa/sdr/ecosystem-0.95-1-6deb253-sdr-transceiver-hpsdr.zip?dl=1

Entpacken und alles auf eine leere formatierte Karte kopieren.

Dann würde ich die letzte PowerSDR - Version 3.4.2 installieren, dann sollte es gehen, wenn kein Hardwarefehler vorliegt.

73 Jörg

Re: Audio Codec minimiert delay

Verfasst: 10 Aug 2017, 19:22
von DL5BCA
Hallo Jörg,

danke für die schnelle Antwort.

Genau das hat geholfen... Jetzt läuft es.... Ganz vielen Dank!

Eine kleine Anregung von mir:
Ich bin ja ganz frisch mit dem RP. Ich habe dann die drei Anleitungen in Software durchgearbeitet..
Das funktionierte dann ja nicht richtig.
Ich würde vielleicht diese kurze Installationsbeschreibung, die Du mir geschrieben hast, dort einfügen.
Das erspart einem, mit RP noch nicht versierten OM, sehr viel Kopfschmerzen.

Ich möchte mich aber bei Dir bedanken, daß Du hier das Forum betreibst und diese Infos bereit hältst.

73 Thomas DL5BCA

Re: Audio Codec minimiert delay

Verfasst: 10 Aug 2017, 20:19
von DD8JM
Hallo Thomas,

schön dass es jetzt geht.

Über die Entwicklungszeit hat sich beim Red Pitaya was Software und Hardware anbelangt vieles getan.
Die Installationsbeschreibung zum Red Pitaya Teil 1 ist vom Feb 09, 2016, da wurde die Softwareinstallation noch anders gemacht.

Du hast Recht, man müsste die Installationsanweisung aktualisieren.

Ich verstehe auch, dass man das Forum nicht Komplet durcharbeiten kann, ich habe es an anderen Stellen schon mal beschrieben.

http://forum.cq-nrw.de/viewtopic.php?f=11&t=147&p=1098&hilit=getting#p1098
http://forum.cq-nrw.de/viewtopic.php?f=40&t=140&p=1049&hilit=getting#p1049

Besonders als Einsteiger fehlt auch der Überblick um zu erkennen ob dieser oder jener Hinweis wichtig ist.

Wenn die dunklen Tage kommen werde ich das Forum aufräumen. ;)

Viele Grüße

Jörg de DD8JM

PS Habe die Installationsanweisung geändert, http://forum.cq-nrw.de/viewtopic.php?f=25&t=16&p=39#p39

Re: Audio Codec minimiert delay

Verfasst: 10 Aug 2017, 21:07
von DL5BCA
Hallo Jörg,

super, vielen Dank...

73 Thomas