Seite 1 von 1

Installationsproblem mit Pavels Software

Verfasst: 24 Sep 2018, 18:40
von dk4rw
Hallo,
ich habe ein Problem mit der Installation von Pavels Software
red-pitaya-alpine-3.6-armhf-20180523

Nach Pavels Anleitung
http://pavel-demin.github.io/red-pitaya ... iver-wspr/
habe ich
- das .zip Archiv heruntergeladen,
- mit 7-Zip entpackt auf einem PC mit Win7Pro 64 Bit,
- die dabei entstandenen Files und Ordner ohne irgendwelche Änderungen per Copy&Paste auf eine FAT32 formatierte SD Karte geschrieben
- die SD Karte in den Red Pitaya gesteckt und die Stromversorgung angeschlossen.
Die grüne LED (Power) und die blaue LED (FPGA) leuchten sofort, LED 0 (ganz links) blinkt im Sekundentakt.
Sowohl die SD LED (gelb) als auch die CPU heartbeat LED (rot) bleiben aus.

Ein paar mögliche Fehler habe ich ausgeschlossen:
- der Red Pitaya funktioniert mit dem mitgelieferten Red Pitya OS
- ein heruntergeladenes und nach Red Pitaya Doku "Quick start" mit Win32DiskImager auf SD geschriebenes Image funktioniert
- mit verschiedenen SD Karten ergibt sich mit Pavels Software immer das gleiche Fehlerbild
Hardware, Netzteil und SD Karten scheiden m.E. damit als Fehlerursachen aus. Es bleibt nur das Entpacken und Beschreiben der SD Karte. Aber was mache ich dabei falsch?

Vielen Dank für Tipps und Hinweise

73, Wolfgang DK4RW

Re: Installationsproblem mit Pavels Software

Verfasst: 24 Sep 2018, 21:28
von DL2BBF
hallo Wolfgang,
hört sich alles richtig an.
ich habe nicht die allerletzte Version aber bereits mit alpine Betriebsystem.

Das Blinken der LED ganz links dauert >20sekunden. Geht dann aus und das system ist bereit.

Re: Installationsproblem mit Pavels Software

Verfasst: 24 Sep 2018, 22:10
von dk4rw
Hallo Hans,
vielen Dank für Deinen Tipp.
Natürlich habe ich es gleich ausprobiert. LED 0 blinkt zwar auch nach 5 min noch, wenn man denn so lange wartet. Aber etwa 30 s nach Einschalten reagiert das System. Wählt man dann eine andere Applikation als "LED blinker" erlöscht LED 0.
Ganz, ganz herzlichen Dank für den richtigen Hinweis und für Deine schnelle Hilfe. Du hast mir wirklich _sehr_ geholfen.

73, Wolfgang DK4RW

Re: Installationsproblem mit Pavels Software

Verfasst: 25 Sep 2018, 16:05
von DD8JM
Es fehlt die Start.sh und Stop.sh im Root-Verzeichnis, diese muss man aus dem Verzeichnis kopieren dessen Application man starten möchte, im Falle von HPSDR aus dem Verzeichnis apps/sdr_transceiver_hpsdr.

73 Jörg DD8JM

PS Grüße aus dem Sauerland, mit dem Wohnmobil unterwegs.

Re: Installationsproblem mit Pavels Software

Verfasst: 25 Sep 2018, 17:24
von DL2BBF
danke für die Ergänzung Jörg

Re: Installationsproblem mit Pavels Software

Verfasst: 25 Sep 2018, 18:09
von DH1KLM
die Start / Stop.sh im Root ist aber nur erforderlich wenn man eine bestimmte Applikation automatisch starten lassen möchte.

Re: Installationsproblem mit Pavels Software

Verfasst: 25 Sep 2018, 18:20
von DD8JM
Das hatte ich so beschrieben, ich dachte das ist sein Problem und der Multiband WSPR transceiver startet bei ihm nicht.
Ich habe es Anhand HPSDR erklären wollen, vielleicht schildert Wolfgang nochmals genauer was er machen will.

Getting startedDownload SD card image zip file
(more details about the SD card image can be found at this link).
Copy the content of the SD card image zip file to an SD card.
Optionally, to start the application automatically at boot time,
copy its start.sh file from apps/sdr_transceiver_wspr to the topmost directory on the SD card.

Insert the SD card in Red Pitaya and connect the power.

Re: Installationsproblem mit Pavels Software

Verfasst: 25 Sep 2018, 20:13
von dk4rw
Hallo zusammen,
mein Ziel ist, den RP als 8 Band WSPR Reoprter laufen zu lassen. Bisher betreibe ich einen RX mit WSJT-X und band hopping.

Zum meinem Problem: es war nicht das fehlende start.sh. Ich wollte einfach nur Pavels Software auf den RP bringen und mit dem Webbrowser mit rp-f0xxx/local starten. Das funktioniert - man muss eben nur rund eine halbe Minute warten, ehe man auf das System zugreifen kann. Mit start.sh im Root Verzeichnis geht LED0 (ganz links) nach einer Weile aus und WSPR sollte laufen.

Irgendwo klemmt es aber noch. Call und Locator ist in decode-wspr.sh eingetragen, ein Stück Leitung an IN1 angeschlossen, aber ein WSPR TX, der im gleichen Raum steht wird offenbar nicht gespottet oder der Spot wird nicht hochgeladen. Mit einem Kontroll-RX kann das S9 Signal problemlos decodiert werden.
Frage: gibt es eine Möglichkeit nachzusehen, was der RP treibt?

73 Wolfgang DK4RW

Re: Installationsproblem mit Pavels Software

Verfasst: 25 Sep 2018, 22:05
von DH1KLM
Also die ersten erzeugten Dateien sind nach ca. 1 min im Verzeichnis /dev/shm/ zu finden. Nach weiteren 3 min füllt sich das Verzeichnis mit weiteren Dateien.
Ein kompletter Durchlauf dauert ca. 5 min, danach sollte auf http://wspr.aprsinfo.com/ ein Ergebnis zu sehen sein.

Die gehörten Stationen sind auch in den Dateien hashtable.txt, wspr_spots.txt .in /dev/shm/ zu sehen und in decode_wspr.log kannst du auch sehen was er so gemacht hat.
Alternativ kannst du auch in der Konsole ps eingeben um die aktuellen Prozesse zu sehen.

ps.PNG


ps1.PNG


Oder pstree

pstree.PNG


Die Linuxer unter uns haben da bestimmt noch weitere Möglichkeiten.
Evtl. gibt es ja einen Befehl um z.B. bestimmte Prozesse permanent auf einer Konsole auszugeben.

Re: Installationsproblem mit Pavels Software

Verfasst: 29 Sep 2018, 08:56
von dk4rw
Sigi, Dein Hinweis auf die im Betrieb entstehenden Dateien war genau die Information, die mir fehlte. In decode_wspr.log konnte ich sehen, dass decode-wspr.sh nicht gelesen werden kann. So kann WSPR natürlich nicht starten. Vermutlich ist beim Editieren von decode-wspr.sh unter Win7 etwas schief gegangen.
Deswegen habe ich unter Lubuntu Pavels .zip direkt auf die SD Karte entpackt und dort die notwendigen Änderungen in decode-wspr.sh (Call, Locator) und in write-c2-files.cfg (80m, 60m Frequenzen) gemacht. Damit funktionierte WSPR jetzt. Selbst ohne Vorverstärker mit nur 50 cm Draht am Eingang hat der Red Pitaya WSPR auf 160m und 80m decodiert. Ich bin begeistert.

Es waren also alles hausgemachte Schwierigkeiten, fehlede Informationen und zu allem Überfluss eine nicht richtig funktionierende SD-Karte.

Nochmals vielen Dank an Euch alle für die sehr hilfreichen Hinweise und die prompte Unterstützung!

73 Wolfgang DK4RW