LinHPSDR und Mint

Linuxversion von HPSDR
Antworten
Benutzeravatar
DL1YAR
Offline
Beiträge: 2
Registriert: Do Nov 22, 2018 5:39 pm

LinHPSDR und Mint

Beitrag von DL1YAR » Do Nov 22, 2018 6:38 pm


Hallo an Alle zunächstmal,
ich ärgere mich aktuell mit linHPSDR und dem aktuellen Linux Mint rum. Hat hier schon jemand linHPSDR und PULSEAUDIO zum Tönen gebracht?
Ich kann die Signale alle sehen, aber bekomme keine NF zu hören.

vy73 de Winfried(DL1YAR)

Benutzeravatar
DK1WP
Offline
Beiträge: 7
Registriert: Fr Nov 10, 2017 7:49 am
Kontaktdaten:

Re: LinHPSDR und Mint

Beitrag von DK1WP » Fr Nov 23, 2018 9:31 am


Hallo Winfried,
deine Mitteilung gehört eingentlich unter "Installation LinHPSDR Linux".

Hast du nach der Installation die Eintrage für PulsAudio gem. dem Dokument "Configuring linHPSDR to work with WSJT-X" vorgenommen?

Adding the pseudo devices.
To add the pseudo devices the file ~/.config/pulse/default.pa must be edited or created if it does not exist.
Add the following lines and then save the file:
.include /etc/pulse/default.pa

### linHPSDR
load-module module-null-sink sink_name=linHPSDR sink_properties="device.description='RX0 Audio'"
load-module module-null-sink sink_name=linHPSDR sink_properties="device.description='TX Audio'"

Note that you could add multiple receiver sinks for RX0 to RX6.
PulseAuido must to be restarted to load the pseudo devices using the following command:
pulseaudio -k

Viel Erfolgt, 73 Marcus DK1WP
vy 73 Marcus DK1WP

Benutzeravatar
DL1YAR
Offline
Beiträge: 2
Registriert: Do Nov 22, 2018 5:39 pm

Re: LinHPSDR und Mint

Beitrag von DL1YAR » Fr Nov 23, 2018 2:30 pm


Danke
jetzt sehe ich zwar die Eingänge im Controllcenter, aber zu hören gibt es leider immer noch nichts. Ich weiss zwar "der Fehler liegt vor dem Laptop" aber mein Linux weigert sich strickt
vy 73 de Winfried

Benutzeravatar
f6itu
Offline
Beiträge: 45
Registriert: Fr Sep 29, 2017 7:13 pm

Re: LinHPSDR und Mint

Beitrag von f6itu » So Nov 25, 2018 12:36 pm


Hi Winfried
- did you configure PulseAudio to "connect" the linhpsdr input on "simultaneous output to audio internal analog stereo" ? as long as PulseAudio don't "see" linhpsdr, you won't be able to ear anything... you'll have to fiddle a little bit (output and input peripherals etc... try the different tab of the PulseAudio volume control window
- in LinHPSDR /configure button (main window)/ Tab "RX-0"/bottom of the popup windows, did your check the "local audio" checkbox ? did you choose the right "audio output" channel (in my config : simultaneous output to audio etc etc)

the "audio checkbox" is viciously hidden in a submenu... I had the same problem looking for it and trying to listen my rig

Hope it could help
73'
Marc f6itu

Antworten